Back to overview

Updates to Match Stats Bot

Apr 20, 2026 at 4:28am UTC
Affected services
Corestats(BOT)

Resolved
Apr 20, 2026 at 4:28am UTC

We’re back! Match Stats Bot should be up and running.